Úvodní informace o programu DreamCom

Kubik SMS DreamCom

Tento program je určen na rozesílání SMS zpráv zejména po ČR, ale také do celého světa.

Kdo nemá chuť na dlouhé čtení, tady je jakýsi nejstručnější návod:

Instalace

Spusťte instalační soubor a vyberte adresář, do kterého chcete program nainstalovat. Při prvním spuštění se objeví okno Nastavení, to odklepnete a rovnou začnete posílat zprávy.

Psaní zpráv

Napíšete číslo adresáta dáte Enter, napíšete zprávu, vyberete typ odesílání zprávy, dáte Ctrl+Enter a zpráva je odeslána. Pokud zadáte číslo, které ještě není v adresáři, automaticky se objeví možnost číslo uložit.

Tento program je shareware, registrační poplatek je 100 Kč. Neregistrovaná verze je plně funkční, jen se zobrazuje okno s reklamním pruhem, na které musíte po určitém čase kliknout. Informace o Registraci najdete zde.

Nahoru


Nastavení

V okně Nastavení se upravují parametry, které zásadním způsobem ovlivňují chování programu. Dodatečné informace získáte kliknutím na příslušnou část obrázku.

Vzhled a chování

Nastavení odeslání

SMTP nastavení

Nastavení pro odesílání emailu (a tedy i SMSEmailu), nejdříve zkuste tlačítko Načíst, pokud používate emailového klienta Microsoft Outlook, bude nastavení načteno z registru.

Host je SMTP server, server, který zabezpečuje rozesílání emailu. Každý poskytovatel internetu vám musí sdělit adresu smtp serveru, který máte používat na odesílání pošty. U Volny je to smtp.volny.cz u IOL mail.iol.cz, atd. Někdy je třeba se nejdříve autorizovat na tomto serveru, což slouží k tomu, aby služby serveru nemohl využívat kdokoliv. K tomu slouží User ID (uživatelské jméno) zpravidla je to, co máte napsáno před zavináčem ve vaší emailové adrese. Pokud posíláte přes web není potřeba nic vyplňovat.

Uživatel

Email je email na který máte program zaregistrován. Používá se např. při identifikaci nebo při přihlašování k některým SMS branám. Jméno a číslo mobilního telefonu se používá rovněž k identifikaci.

SMSEmail

Volba Zachovat celá slova zajišťuje, aby při posílání dlouhé zprávy nebylo poslední slovo rozděleno, ale přesunuto do další zprávy. Tato funkce funguje jen u SMSEmailu, při odesílání přes WWW, zařizují lámání www skripty.

Pauza při odesílání je také určena pro odesílání přes SMSemail, je tam proto aby zprávy došly ve správném pořadí, jejich pořadí můžete také otočit.

Automatické úpravy

Pokud chcete automaticky přidávat Oslovení (na začátek zprávy) a Podpis (na konec) do zprávy, zaškrtněte tato políčka (jejich hodnoty se načítají z Adresáře). Nastavte si zde také váš implicitní Podpis. Kliknutím na tlačítko Natavit se ke všem položkám v adresáři přiřadí zadaný podpis.

Pokud zaškrtnete Posílat vždy bez háčků, budou ze zprávy před odesláním odstraněny háčky a čárky.

Po aktivaci volby Doplňovat kód země a vybrání státu ze seznamu bude při použití čísla bez kódu státu tento kód automaticky doplněn.

Vlastnosti textu

Tlačítkem Barva pozadí nastavíte barvu pozadí textu při psaní zprávy. Zbylá dvě tlačítka nastavují typ, velikost a barvu fontu. Tyto vlastnosti se použijí při psaní zprávy, a zajistí vizuelní odlišení lichých a sudých zpráv, tak jak budou rozděleny při odeslání.

Nastavení proxy pro WWW

Nastavte jen v případě, že máte výhradní připojení na internet přes proxy server (u lokálních sítí, nikoliv u modemu). Port uveďte za dvojtečku.

Chování programu

Ikona do traye zajistí, aby se v systémové části hlavního panelu (tzv. tray) zobrazovala ikona DreamComu. Zaškrtnutím Minimalizace do traye bude program minimalizován pouze do traye (neobjeví se mezi ostatními aplikacemi v hlavním panelu).

Po odeslání odpojit aktivujte, jestliže chcete, aby se po odeslání všech zpráv z fronty DreamCom odpojil od internetu (funguje jen pro připojení modemem).

Pokud zvolíte Upozorňovat na nové verze, budete při startu programu automaticky upozorněni na případné nové verze DreamComu a skriptů (viz aktualizace).

Připojit se pokud nejsem online zajistí, aby se DreamCom automaticky připojil k internetu při zařazení zprávy do fronty. Pokud volbu nezvolíte, můžete se stále připojit kliknutím na tlačítko [image] nebo [image] v okně fronty.

Volby Zobrazovat okno fronty, událostí a adresáře skryjí či zobrazí výše uvedená okna.

Pokud vyberete Při ukončení hlídat zprávy ve frontě, budete při ukončení programu upozorněni na případné zprávy ve frontě.

Pokud vyberete Nové číslo jako dočasnou položku, bude každé nové číslo (číslo nenacházející se v adresáři) automaticky zařazeno jako dočasná položka.

Spouštět minimalizovaně způsobí, že bude DreamCom při každém spuštění minimalizován.

Máte také možnost chránit historii heslem proti neoprávněným přístupům. Heslo zadejte po stisknutí tlačítka Změnit. Jestliže chcete tuto ochranu zrušit, stiskněte opět Změnit, zadejte staré heslo, a když budete požádáni o nové heslo, nechte obě políčka prázdná.

Časové limity

Limit pro načtení stránky stanoví čas, po který se program bude snažit načíst webovou stránku (při odesílání přes web). Pokud se vám při odesílání zprávy v Okně událostí často objevuje hláška typu "operace byla zrušena", zvyšte hodnotu limitu. Pokud se nepodaří odeslat zprávu, nebo pokud bylo odesílání uživatelem přerušeno, bude odesílání odloženo o hodnotu zadanou v Po přerušení odložit o ... s.


Hlavní okno

Informace o hlavním oknu získáte kliknutím na příslušnou část obrázku.

Tlačítková lišta

V tlačítkové liště jsou soustředěny nejpoužívanější funkce z hlavní nabídky:

options.bmp (246 bytes) (Alt+N) Otevře okno Nastavení.

crdfile2.bmp (246 bytes) (Alt+A) Otevře databázové okno Adresář.

animatn.bmp (246 bytes) (Alt+F) Otevře databázové okno Fronta.

docstack.bmp (246 bytes) (Alt+H) Otevře databázové okno Historie.

skup.bmp (870 bytes) (Alt+S) Otevře databázové okno Skupiny.

odkazy.gif (982 bytes) (Alt+O) Otevře databázové okno Odkazy. Kliknutím na trojúhelník vedle ikonky se otevře nabídka odkazů. Kliknutím na vybraný odkaz se tento otevře v prohlížeči.

crdfile3.bmp (246 bytes) (Alt+P) Otevře databázové okno Přednastavené zprávy. Kliknutím na trojúhelník vedle ikonky se otevře nabídka přednastavených zpráv.

adrokno.bmp (1334 bytes) (F2) Zobrazí/schová adresář.

display1.bmp (1418 bytes) (Alt+D) Zapne funkci Přímo na displej. Odesílanou zprávu pošle přímo na displej mobilního telefonu (tzv. Flash SMS).

dorucenka.bmp (1334 bytes) (Alt+P) Zapne funkci Doručenka. SMS centrum pošle potvrzení o přijetí zprávy.

identifikace.bmp (774 bytes) (Alt+I) Zapne funkci Identifikace. K odesílané zprávě jsou připojeny informace o odesílateli (jaké záleží na SMS bráně operátora).

Pokud je některé z tří výše uvedených tlačítek zakázáno, SMS brána vybraného operátora tuto funkci nepodporuje. Tyto funkce nejsou aktivní pro odesílání zprávy přes Email a SMSEmail.

zavrit.bmp (246 bytes) (Alt+F4) Ukončí aplikaci DreamCom.

Z hlavní nabídky dále můžete uložit a zálohovat databáze:

(Ctrl+S) Ručně uloží všechny databáze. Více informací viz Důležitá poznámka.

(Ctrl+Z) Provede zálohu všech databází. Soubory se ukládají do adresáře \Backup.

(Ctrl+O) Provede obnovu databází ze zálohy.

Adresář

Zajišťuje rychlý přístup k osobám v seznamu. Před odesláním zprávy je nutno nejprve zaškrtnout alespoň jednu osobu z adresáře. Stisknutím pravého tlačítka myši v okně adresáře vyvoláte kontextovou nabídku, z které máte možnost smazat osobu ze skupiny (ve skupině Všichni z adresáře) nebo vyvolat editační okno adresáře. Rychlé přesouvání jmen ze skupin je možné pouhým přetažením položky ze seznamu a upuštěním na požadovanou záložku skupiny.

Vyhledávat jména nebo čísla je možné přímo v adresáři (nemusíte se přesouvat do vyhledávací řádky). Stisknutím klávesy Enter se přesunete přímo do editoru textu. Jméno se zaškrtává buď kliknutím myši na čtvereček nalevo od jména nebo stisknutím mezerníku.

Přesunout jméno do jiné skupiny můžete přetažením jména (pomocí myši) a následným upuštěním na požadovanou záložku skupiny. V případě, že přetahujete jméno ze skupiny Všichni, nedojde k jeho přesunutí ale k překopírování.

S adresářem jsou spojena následující tlačítka:

sum.bmp (246 bytes) (Alt+W) Zatrhne všechny osoby v aktivní skupině.

clear.bmp (246 bytes) (Alt+Z) Zruší zatržení u všech osob v aktivní skupině.

skup.bmp (870 bytes) (Alt+G) Zapíná či vypíná skupinový mód. Pokud je tlačítko stisknuto (je dole), je aktivováno posílání zpráv skupině osob a můžete v adresáři zaškrtnout několik osob. Pokud tlačítko není stisknuto (je nahoře), můžete v adresáři vybrat jen jednu osobu. Jestliže je zapnut skupinový mód jsou zakázána tlačítka Přímo na displej, Doručenka a Identifikace a potřebné údaje se berou z adresáře pro každého adresáta zvášť.

V pravém dolním rohu adresáře se zobrazuje počet vybraných jmen.

Fronta

Ve frontě jsou seřazeny zprávy, které čekají na odeslání. Položka ve frontě je označena jménem adresáta a barevnou ikonkou. Zelená ikonka znamená, že zpráva se právě odesílá nebo je připravena k odeslání (např. čeká na časový limit SMS brány). Oranžová ikonka znamená, že zařazená zpráva bude odeslána do hodiny. Červená ikonka znamená, že zpráva bude odeslána za více než hodinu, popř. že nejste právě připojeni k internetu (ve s stavovém panelu je nápis Offline). Pro rychlou práci se zprávami ve frontě je určeno několik tlačítek:

Dokud je tlačítko stisknuto, je pozastaveno odesílání všech dalších zpráv z fronty. Zpráva, jejíž odeslání již bylo započato, se ještě odešle.

(P) Přeruší odesílání vybrané zprávy z fronty a posune čas odeslání o 10 minut.

smazat.bmp (246 bytes) (Del) Odstraní vybranou zprávu z fronty.

editace.bmp (246 bytes) (Enter/Dvojklik) Pokud není vybrána žádná položka, otevře se databázové okno Fronta, kde máte možnost dále se zprávou pracovat (editovat, odstranit, poslat ihned atd.). Jestliže je nějaká položka vybrána, zobrazí se přímo okno pro editaci položky ve frontě.

obalka.bmp (246 bytes) (Space) Pošle ihned vybranou zprávu z fronty (nastaví čas odeslání na aktuální).

vsechny.bmp (246 bytes) (Ctrl+Space) Pošle ihned všechny zprávy z fronty (nastaví čas odeslání na aktuální).

Poznámka: Klávesové zkratky jsou platné jen v případě, že se nacházíte v okně fronty. Stisknutím pravého tlačítka myši v okně fronty vyvoláte kontextovou nabídku.

Vyhledávací řádka

Je určena k rychlému vyhledávání osob v adresáři. Napište část jména nebo čísla, které chcete vyhledat, a pokud bude odpovídající jméno (číslo) nalezeno, zaškrtne se v adresáři. Pokud je stisknuto tlačítko skup.bmp (870 bytes) pro skupinový mód, vyhledaná osoba není zaškrtnuta automaticky (je pouze modře vysvícena). Musíte ji zaškrtnout ručně (klávesou INS nebo kliknutím na čtvereček nalevo od jména).

Pro usnadnění práce slouží ve vyhledávací řádce několik klávesových zkratek:

  • Enter - Kurzor se přesune z vyhledávací řádky do editoru.
  • Ins - Zaškrtne (zruší zaškrtnutí) modře vysvícené jméno v adresáři. Zadáte-li číslo, které není v seznamu zobrazí se po stisknutí klávesy Ins dotaz, zda chcete číslo přidat do seznamu.
  • Esc - Text ve vyhledávací řádce se smaže.
  • PgUp - Posune se ve skupinách o jednu skupinu doleva.
  • PgDn - Posune se ve skupinách o jednu skupinu doprava.

Způsob odeslání

Určuje způsob, jakým bude zpráva odeslána:

  • W (Web) - přes SMS bránu, prostřednictvím vybraného skriptu (Ctrl+1)
  • S (SMSEmail) - emailem na mobilní telefon (Ctrl+2)
  • E (Email) - na klasický email (Ctrl+3)

Více informací naleznete zde.

Skripty

Skripty slouží k odesílání zpráv přes SMS bránu mobilního operátora. Vybrat skript můžete jen v případě, že máte způsob odeslání nastaven na Web. Pokud máte u dané osoby v Adresáři nastaven skript pro odeslání přes web, skript se při výběru osoby automaticky nastaví. Pokud nemáte implicitní skript nastaven, DreamCom se pokusí podle předčíslí vhodný skript najít. Pro ruční výběr skriptu slouží klávesová zkratka Ctrl+0.

Skripty můžete editovat či vytvářet v Editoru skriptů.

Skupiny

Kliknutím na záložku vyberete požadovanou skupinu. V adresáři se pak zobrazí pouze jména, která přísluší vybrané skupině. Speciální význam má skupina Všichni. Je to skupina, která obsahuje všechna jména ze všech skupin. Mezi záložkami je vždy na prvním místě a není možné ji odstranit.

Dvojkliknutím na záložku skupiny se otevře okno Skupiny s možností editovat zvolenou skupinu.

Podrobnosti o práci se skupinami naleznete zde.

Časové limity SMS bran

V tomto okně se průběžně zobrazuje za kolik vteřin vyprší čas, za který bude moci být SMS brána použita. Pokud brána v tomto okně není zobrazena, může být použita okamžitě.

Ukazatele počtu zbývajících znaků

Slouží k rychlé orientaci, kolik znaků ještě zbývá do vyčerpání limitu. Levý ukazatel zobrazuje kolik znaků zbývá do rozdělení zprávy, pravý kolik znaků zbývá celkem.

Editor textu

Slouží k vlastnímu psaní zpráv. Text je také možné vkládat se schránky (Ctrl+V). Informace o zbývajících znacích se zobrazují ve stavovém panelu. Přímo do textu můžete vkládat přednastavené zprávy z tlačítkové lišty nebo pomocí klávesové zkratky.

Stisknutím pravého tlačítka myši v okně editoru vyvoláte kontextovou nabídku. Vybráním položky Nová zpráva (Ctrl+N) připravíte DreamCom na psaní další zprávy (zruší se zaškrtnutí v adresáři a vymaže se editor textu).

Okno událostí

Okno, v kterém se zobrazují aktuální události, např. hlášení o odesílaných zprávách, stahovaných aktualizacích, chybách ve skriptu atd.

Dvojkliknutím na okno událostí se otevře Historie.

Stavový panel

Ve stavovém panelu se průběžně zobrazují některé důležité informace:

  1. sekce - jméno a číslo (email) vybrané osoby
  2. sekce - nápis Online, pokud jste právě připojeni k internetu nebo Offline, pokud ne
  3. sekce - celkový počet napsaných znaků
  4. sekce - počet znaků, který zbývá do rozdělení zprávy
  5. sekce - počet zpráv, na které bude text rozdělen

Tlačítka na poslání zprávy

Tlačítkem Poslat (Ctrl+Enter) pošlete zprávu ihned (zpráva je zařazena do fronty a čas odeslání nastaven na aktuální). Stisknutím tlačítka [image] (Poslat jindy) (Ctrl+J) otevřete okno Nastavení času odeslání:

PoslatJindy.gif (5421 bytes)

Zde máte možnost nastavit, datum a čas odeslání zprávy, zda se má odeslání opakovat a jakým způsobem. Pokud nastavíte Poslat na 0 krát, bude zpráva odeslána jen jednou. Nastavíte-li Poslat na 1 krát bude zpráva odeslána celkem dvakrát atd. Můžete ještě určit v jakých časových intervalech se má odeslání opakovat.

Zprávu můžete také poslat z příkazové řádky.


Zpusoby odesílání

Způsoby odesílání

DreamCom umožňuje posílat SMS zprávy několika způsoby:

  • Přes www rozhraní mobilních operátorů.
  • Někteří operátoři podporují emaily, nazývané SMSEmail. Např. pro Eurotel ve tvaru cislo@sms.eurotel.cz pro Paegas cislo@sms.paegas.cz nebo jmeno.prijmeni@sms.paegas.cz nebo jmeno@click.cz. Na Oskar prezdivka@mujoskar.cz.
  • Je také možné posílat klasický email.

Pokud chcete posílat email, musíte mít správně nastaven SMTP server (info zde). Pokud budete zprávy posílat jen přes www, není třeba nic nastavovat, jen v případě, že máte přístup přes proxy server (někdy ve firmách) vyplníte proxy server v Nastavení.

Krátké porovnání způsobů:

  • Přes www českých operátorů je možné poslat emaily na všechny mobily v ČR, najednou můžete poslat až 5 zpráv (kolem 750 znaku), doručení je rychlé a relativně spolehlivé. Aby se tyto servery nezneužívaly, je u Paegasu stanoven časový limit na 120 sekund a u Eurotelu 30 sekund, častěji SMS zprávy nepošlete. Pokud používáte proxy, kterou samozřejmě může využívat více lidí, může být problém zprávu odeslat, proto je dobré proxy pro odesílání nepoužívat (v nastavení proxy v IE dejte aby nepoužíval pro sms.paegas.cz). Je možné zasílat zprávy anonymně.
  • Posílání přes email není omezeno počtem zpráv, není tam žádné časové omezení, ale nelze posílat na všechny mobily (Např. u Paegasu paušálu se to musí objednat) a někdy trvá doručení déle. Ve zprávě je vždy vaše emailová adresa.


Adresář

Okno Adresář slouží k úpravě informací o osobě v seznamu adresátů, příp. při přidávání nové osoby do seznamu. Dodatečné informace získáte kliknutím na příslušnou část obrázku.

Jméno

Jméno, pod kterým bude daný adresát evidován.

Číslo

Číslo mobilního telefonu v mezinárodním formátu. Pokud máte v nastavení zaškrtnutou volbu doplňovat kód země, přidává se kód země automaticky při vstupu do políčka.

SMSEmail

Pokud je políčko prázdné, je SMSEmail automaticky generován po zadání čísla. Generovaný SMSEmail je závislý na nastavení databáze SMSEmail.

Email

Email adresáta.

Oslovení

Text, který se bude přidávat na začátek každé zprávy (pokud je v nastavení zaškrtnuta volba přidávat oslovení). Vyplněním oslovení ušetříte čas při psaní jednotlivých zpráv. Tato funkce je také užitečná při hromadné korespondenci - i když píšete skupině osob, každá je oslovena svým jménem.

Podpis

Text, který se bude přidávat na konec každé zprávy (pokud je v nastavení zaškrtnuta volba přidávat podpisy). Pro každou osobu v adresáři si můžete nastavit jiný podpis či pozdrav.

Způsob

Určuje preferovaný způsob odeslání zprávy. Způsob odeslání bude automaticky nataven na Web, SMSEmail nebo Email. Pokud vyberete Neměnit, nebude se způsob odeslání měnit (použije se naposled použitý). Více o způsobech odeslání zjistíte zde.

Skript

Určuje skript (SMS bránu), který bude automaticky použit při odesílání zprávy přes Web. Skripty můžete editovat či vytvářet v editoru skriptů, který je přístupný přes databázové okno skriptů.

Přepínače

Určuje, jakým způsobem bude zpráva odeslána. Pokud zvolený operátor (jeho SMS brána) příslušnou funkci nepodporuje, je zatržítko zakázáno. Používají se jen při odeslání pře Web.

  • Přímo na displej - tzv. flash SMS, zpráva se zobrazí přímo na displeji mob. telefonu (neuloží se do seznamu přijatých zpráv).
  • Doručenka - z SMS centra operátora přijde potvrzení o přijetí SMS zprávy.
  • Identifikace - k SMS zprávě jsou přidány informace o odesílateli.

Skupiny

U každé osoby v adresáři můžete zvolit, do které skupiny bude zařazena. V okně Přiřazené skupiny jsou skupiny v kterých už daná osoba figuruje. Naopak v okně Nepřiřazené skupiny jsou skupiny, v kterých daná osoba není. Novou skupinu přiřadíte zatržením skupiny v okně Nepřiřazené skupiny a kliknutím na tlačítko Přidat. Odebrání osoby ze skupiny se provede zatržením skupiny v okně Přiřazené skupiny a kliknutím na tlačítko Odebrat. Vytvářet, editovat a mazat skupiny můžete v okně Skupiny.


Práce s databázemi

K databázím máte přístup z nabídky Nastavení. Častěji používané jsou dostupné přímo z tlačítkové lišty. Nejrychleji se však k databázím dostanete použitím klávesové zkratky. Zde je seznam databází:

crdfile2.bmp (246 bytes) (Alt+A) Adresář

animatn.bmp (246 bytes) (Alt+F) Fronta

docstack.bmp (246 bytes) (Alt+H) Historie

skup.bmp (870 bytes) (Alt+S) Skupiny

mail.bmp (246 bytes) (Alt+E) SMSEmail

crdfile3.bmp (246 bytes) (Alt+P) Přednastavené zprávy

globe.gif (181 bytes) (Alt+K) Kódy států

gears.gif (151 bytes) (Alt+Y) Skripty

internet.gif (822 bytes) (Alt+O) Odkazy

Důležitá poznámka: Všechny databáze se ukládají do souborů až při ukončení aplikace. Pokud chcete mít jistotu, že při případné havárii systému nepřijdete o nově vytvořené položky, uložte databáze ručně - Program/Uložit databáze (Ctrl+S). Výjimku tvoří Fronta a Historie, ty se ukládají po každém úspěšném odeslání zprávy, což by mělo zvýšit bezpečnost. Má to ale i své nevýhody. Pokud je již Historie objemnější, může její časté ukládaní zpomalovat chod systému. V takovém případě je vhodné smazat starší nebo nepotřebnou část Historie.

Adresář

Adresář slouží k vedení kontaktů.

V databázovém okně adresáře máte možnost přidávat nové kontakty - kliknutím na tlačítko novy.gif (134 bytes) nebo stisknutím klávesy Ins, můžete upravovat existující kontakty - kliknutím na tlačítko editace.gif (151 bytes), dvojklikem na vybranou položku nebo stisknutím klávesy Enter na vybrané položce. V obou případech se otevře okno k editaci adresářové položky. Tlačítkem smazat.gif (149 bytes) nebo stisknutím klávesy Del smažete vybrané položky.

Tlačítkem import.gif (134 bytes) (Ctrl+I) provedete import adresáře, tlačítkem export.gif (131 bytes) (Ctrl+E) export. Pro import a export se používá textový soubor, jednotlivé položky záznamu (sloupce) jsou odděleny středníkem.

Editační řádka a tlačítko hledej.gif (128 bytes) (Ctrl+F) je určena pro vyhledávání v adresáři. Vyhledává se vždy ve sloupci, podle kterého je adresář seřazen (za názvem sloupce je trojůhelníček). Seřadit adresář podle zvoleného sloupce můžete kliknutím na jeho záhlaví.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Fronta

Ve frontě jsou seřazeny zprávy, které čekají na odeslání.

Kliknutím na tlačítko obalka.gif (126 bytes) (Space) ihned odešlete označené zprávy, tlačítkem vsechny.gif (138 bytes) (Ctrl+Space) odešlete ihned všechny zprávy ve frontě. Můžete také upravovat zprávy zařazené ve frontě - tlačítkem editace.gif (151 bytes) (Enter) nebo dvojkliknutím na požadovanou zprávu. Otevře se okno pro editaci zprávy ve frontě:

EditaceFronty.gif (6355 bytes)

Zde lze měnit adresáta, datum a čas odeslání, způsob odeslání, skript (SMS bránu), text zprávy atd. Tlačítkem smazat.gif (149 bytes) nebo stisknutím klávesy Del smažete vybrané položky, tlačítkem trashful.gif (142 bytes) (Ctrl+Del) smažete všechny položky.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Historie

V historii jsou evidovány všechny odeslané zprávy. Protože se často jedná o citlivé informace, může být často vhodné zabezpečit přístup k historii heslem (viz Nastavení). Tomu, kdo nezná příslušné heslo není náhled do historie povolen.

Tlačítko obalka.gif (126 bytes) (Ctrl+Space) odešle vybranou zprávu z historie. Tlačítkem editace.gif (151 bytes) (Enter) se zpráva zkopíruje do hlavního okna, kde ji lze dále upravovat a posléze odeslat. Tlačítkem smazat.gif (149 bytes) nebo stisknutím klávesy Del smažete vybrané položky, tlačítkem trashful.gif (142 bytes) (Ctrl+Del) smažete všechny položky. Stiskem tlačítka query.gif (130 bytes) (Ctrl+T) se otevře následující okno:

SmazatHistorii.gif (3917 bytes)

Zde zvolíte v jakém časovém intervalu bude historie vymazána (ode dne do dne - včetně). Tlačítkem export.gif (131 bytes) (Ctrl+E) provedete export historie do textového souboru.

Editační řádka a tlačítko hledej.gif (128 bytes) (Ctrl+F) je určena pro vyhledávání v historii. Vyhledává se vždy ve sloupci, podle kterého je historie seřazena (za názvem sloupce je trojůhelníček). Seřadit historii podle zvoleného sloupce můžete kliknutím na jeho záhlaví.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Skupiny

Skupiny jsou množiny jakýmkoli způsobem souvisejících kontaktů. Záleží na uživateli, jaké skupiny si nadefinuje. Speciální význam má skupina Všichni. Je to skupina, která obsahuje všechny kontakty ze všech skupin. Mezi skupinami je vždy na prvním místě a není možné ji odstranit.

Skupiny.gif (9862 bytes)

V sekci Jména skupin jsou uvedena všechny existující skupiny. Kliknutím na označenou skupinu můžete změnit název skupiny. Tlačítkem novy.gif (134 bytes) (Ins) se vytváří nová skupina, tlačítkem smazat.gif (149 bytes) (Del) se smaže označená skupina.

Přímo při editaci skupin máte možnost přiřadit každé skupině kontakty. V seznamu Přiřazená jména jsou kontakty, které již vybraná skupina obsahuje, naopak v seznamu Nepřiřazená jména jsou kontakty, které jsou ještě k dispozici. Kliknutím na tlačítko Přidat se vybrané skupině přiřadí všechna zaškrtnutá jména. Odebrání kontaktů ze skupiny se provádí obdobně.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

SMSEmail

V databázi SMSEmail je seznam mobilních operátorů, kteří podporují posílání emailů přes mobilní telefon.

Uživatel má možnost přidávat nové operátory - tlačítko novy.gif (134 bytes) (Ins), upravovat informace o operátorech - tlačítko editace.gif (151 bytes) (Enter nebo dvojkliknutí myší) a odstraňovat existující operátory - tlačítko smazat.gif (149 bytes) (Del). Pro vytváření nebo editaci operátora slouží toto speciální okno:

SMSEmail.gif (5046 bytes)

Předčíslí je seznam přípustných předčíslí oddělených středníkem. Délka zprávy je maximální délka zprávy. Použití "-E" znamená, že od délky zprávy má být odečtena délka emailu. Email host obsahuje posloupnost znaků, která je v SMSEmailové adrese za zavináčem.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Přednastavené zprávy

Přednastavené zprávy jsou zprávy, které si uložíte do databáze, a pak je můžete opakovaně vkládat do textu nově vytvářených zpráv. Obvykle jsou to často používané úseky textu. K nejpoužívanějším přednastaveným zprávám je vhodné přiřadit klávesovou zkratku. Dávejte si ale pozor, aby nebyla použita zkratka, která již je použita některou interní funkcí DreamComu.

Tlačítkem novy.gif (134 bytes) (Ins) vytvoříte novou přednastavenou zprávu, tlačítkem smazat.gif (149 bytes) (Del) smažete vybranou přednastavenou zprávu, tlačítkem trashful.gif (142 bytes) (Ctrl+Del) smažete všechny zprávy. Tlačítkem import.gif (134 bytes) (Ctrl+I) provedete import přednastavených zpráv, tlačítkem export.gif (131 bytes) (Ctrl+E) export. Pro import a export se používá textový soubor, jednotlivé položky záznamu (sloupce) jsou odděleny středníkem.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Kódy států

Ať v DreamComu použijete jakékoliv číslo, musí (nebo je to nanejvýš vhodné) být v kódech států položka, která danému číslu odpovídá. Kódy států jsou nutné pro správnou činnost skriptů a adresáře.

Tlačítkem novy.gif (134 bytes) (Ins) přidáte nový kód státu, tlačítkem smazat.gif (149 bytes) (Del) smažete vybraný kód, tlačítkem trashful.gif (142 bytes) (Ctrl+Del) smažete všechny kódy. Tlačítkem import.gif (134 bytes) (Ctrl+I) provedete import kódů, tlačítkem export.gif (131 bytes) (Ctrl+E) export. Pro import a export se používá textový soubor, jednotlivé položky záznamu (sloupce) jsou odděleny středníkem.

Editační řádka a tlačítko hledej.gif (128 bytes) (Ctrl+F) je určena pro vyhledávání v kódech států. Vyhledává se vždy ve sloupci, podle kterého jsou kódy seřazeny (za názvem sloupce je trojůhelníček). Seřadit kódy států podle zvoleného sloupce můžete kliknutím na jeho záhlaví.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Skripty

Skripty slouží k odesílání zpráv přes SMS bránu mobilního operátora. Pomocí skriptu můžete přidat jakoukoli SMS bránu. Pokud provozovatel bránu v budoucnu změní, není nutno shánět novou verzi DreamComu, stačí jen stáhnout nový skript nebo starý ručně upravit.

Pro ruční editaci skriptu slouží pomůcka Editor skriptů, který se spouští tlačítkem editace.gif (151 bytes) (Enter). Pokud chcete vytvořit nový skript, stiskněte tlačítko novy.gif (134 bytes) (Ins). Po vytvoření nebo editaci skriptu je k tomu, aby se změna promítla do spuštěného DreamComu nutné stisknout tlačítko refresh.gif (139 bytes) (Ctrl+R) nebo restartovat aplikaci. Pokud chcete z DreamComu nějaký skript vyřadit, smažte z adresáře \Scripts odpovídající soubor s příponou .sms.

Pokud obsahuje vybraný skript nějaký uživatelský parametr, jeho editační řádka se objeví v levé části okna (viz Heslo na obrázku).

Skripty.gif (8741 bytes)

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.

Odkazy

Pokud potřebujete otvírat nějaké internetové stránky otvírat přímo z DreamComu, na tomto místě si je můžete nadefinovat.

Tlačítkem novy.gif (134 bytes) (Ins) vytvoříte nový odkaz, tlačítkem smazat.gif (149 bytes) (Del) smažete vybraný odkaz, tlačítkem trashful.gif (142 bytes) (Ctrl+Del) smažete všechny odkazy. Tlačítkem import.gif (134 bytes) (Ctrl+I) provedete import odkazů z textového souboru, tlačítkem export.gif (131 bytes) (Ctrl+E) export. Pro import a export se používá textový soubor, jednotlivé položky záznamu (sloupce) jsou odděleny středníkem. Tlačítkem [image] (Ctrl+Enter) otevřete odkaz v prohlížeči.

Editační řádka a tlačítko hledej.gif (128 bytes) (Ctrl+F) je určena pro vyhledávání v odkazech. Vyhledává se vždy ve sloupci, podle kterého jsou položky seřazeny (za názvem sloupce je trojůhelníček). Seřadit kódy států podle zvoleného sloupce můžete kliknutím na jeho záhlaví.

Kliknutím pravým tlačítkem myši na jakoukoli položku se otevře kontextová nabídka.


Aktualizace

Pokud máte v Nastavení zatrženo Upozorňovat na nové verze, objeví se po spuštění DreamComu okno Aktualizace (jen v případě, že se na internetu vyskytuje novější verze programu nebo skriptu). Jednorázově lze aktualizaci spustit z menu Program->Aktualizace (Ctrl+U). Objeví se okno podobné následujícímu:

Aktualizace.gif (8823 bytes)

Sekce DreamCom se objeví v případě, že existuje verze novější, než máte nainstalovánu. Jsou zde uvedeny údaje o verzi programu, velikosti a jménu souboru a novinky oproti poslední verzi.

Sekce Nové skripty se objeví v případě, že jsou k dispozici nové skripty nebo nové verze existujících skriptů. U každého skriptu je uvedena verze a stručná charakteristika.

Máte možnost stáhnout novou verzi DreamComu, stáhnout všechny nové skripty a aktualizovat skripty, které již jsou instalovány (označte příslušná zatržítka). Aktualizace se provede stiskem tlačítka OK. Průběžné informace o aktualizaci se vypisují do Okna událostí. Po stažení nové verze DreamComu můžete ihned spustit instalaci.


Příkazová řádka

DreamCom nyní umožňuje posílat zprávy přímo z příkazové řádky. Syntaxe je následující:

dreamcom.exe /num<jméno nebo číslo adresáta> TEXT ZPUSOB PREPINACE

TEXT je text zprávy, může být zadán:

  • přímo: /text<text zpávy>
  • ze souboru: /file<úplná cesta k souboru>

ZPUSOB určuje způsob, jakým bude zpráva odeslána:

  • přes Web: /web
    • můžete určit skript: /script<jméno skriptu>
  • jako SMSEmail: /smsemail
  • jako Email: /email
    • můžete zadat předmět: /subject<předmět zprávy>

PREPINACE určují tyto vlastnosti odeslání (platí jen pro odeslání přes Web):

  • doručenka: /aod
  • přímo na displej: /flash
  • identifikace: /ident

Za parametr /num se zadává číslo nebo jméno adresáta. Číslo je buď v mezinárodním formátu, nebo je mu přiřazen vhodný kód z databáze kódů států. Pokud neuvedete kód státu, v předčíslí neuvádějte úvodní nulu!

Na pořadí parametrů nezáleží.

Pro odesílání zpráv se používá vždy jedna instance programu. Pokud zadáte zprávu z příkazové řádky, a program již je spuštěn, DreamCom se pouze přesune do popředí a zprávy se uloží do fronty.

Příklady

dreamcom.exe /num 605123456 /text Zprava z DreamComu. /web

Pošle zpávu přes Web a vhodný skript se pokusí najít sám.

dreamcom.exe /num 605123456 /text Zprava z DreamComu. /web /script paegas /aod

Pošle zpávu přes Web a pro odeslání zprávy použije skript paegas, pošle doručenku.

dreamcom.exe /num Milan /text Zprava z DreamComu. /smsemail

Pošle Milanovi (musí být v adresáři) zpávu přes SMSEmail.

dreamcom.exe /num Milan /text Zprava z DreamComu. /email /subject Pozdrav

Pošle email z předmětem Pozdrav.

dreamcom.exe /num Milan /file d:\texty\pozdrav.txt /web /ident

Pošle zpávu, kterou načte ze souboru, přes Web a zapne identifikaci.

Dávkové zpracování

Pokud chcete z příkazové řádky odeslat více zpráv, je výhodnější použít dávkové zpracování. Nejdříve si připravíte dávkový soubor (syntaxe je stejná jako u příkazové řádky, jen "dreamcom.exe" je možné vynechat. Pak stačí spustit DreamCom s parametrem /batch a názvem souboru s dávkou.

Příklad příkazové řádky

dreamcom.exe /batch d:\data\davka.txt

Příklad dávkového souboru

/num 605123456 /text Zprava z DreamComu. /web
/num 605123456 /text Zprava z DreamComu. /web /script paegas /aod
/num Milan /text Zprava z DreamComu. /smsemail
/num Milan /text Zprava z DreamComu. /email /subject Pozdrav
/num Milan /file d:\texty\pozdrav.txt /web /ident


Editor skriptů

Editor skriptů slouží k vytváření nebo úpravě skriptů. Je přístupný z databázového okna Skripty. Okno editoru se skládá z klasického editoru textu a panelu, z kterého se vkládají klíčová hesla skriptu. Nápověda se zobrazuje v dolním stavovém panelu.

EditorSkriptu.gif (14760 bytes)

Struktura skriptu

Skript lze rozdělit do dvou základních částí - inicializační a výkonné.

Inicializační část

Komentář

Je vhodné na začátek skriptu uvést několik údajů o skriptu, např. bránu pro kterou je určen, jméno autora, datum vytvoření atd. Tyto informace (a jakékoli jiné) můžete zadat jako komentář. Komentář se uvozuje znakem # (všechny znaky až do konce řádky jsou ignorovány).

Sekce Param

V této sekci se uvádějí parametry, které budou ve skriptu použity. Parametr je následován svou hodnotou. Na každou řádku patří pouze jeden parametr. Patří sem tyto povinné parametry:

  • Version - verze skriptu (formát je x.y)
  • FirstMsgSize - maximální délka 1. zprávy
  • MsgCount - maximální počet zpráv
  • MsgTime - časový limit mezi 2 zprávami v sekundách

Nepovinné parametry:

  • OtherMsgSize - maximální délka ostatních zpráv
  • CountryCode - kód státu platný pro čísla, která budou skript používat
  • Prefixes - seznam přípustných předčíslí oddělených středníkem (bez úvodní nuly)

Dále 5 volitelných uživatelských parametrů. Každý parametr následuje doprovodný text, který se objeví v databázovém okně Skripty.

  • Password - heslo (např. Password Zadejte své heslo)
  • UserPar1 - uživatelský parametr č. 1 (např. UserPar1 Zadejte jméno své manželky)
  • UserPar2 - uživatelský parametr č. 2
  • UserPar3 - uživatelský parametr č. 3
  • UserPar4 - uživatelský parametr č. 4

Sekce přepínačů

Zde je možno volitelně uvést tři druhy přepínačů:

  • AoD - doručenka (Advice of Delivery)
  • Flash - SMS přímo na displej mobilního telefonu
  • Ident - identifikace

Způsob zápisu je stejný pro všechny tři přepínače (viz příklad):

<Název přepínače>
  On <parametry, kterými se přepínač zapíná>
  Off <parametry, kterými se přepínač vypíná>
End

Výkonná část

Sekce stránek

Zde je možno použít dva příkazy - GetPage a PostPage.

GetPage má tuto strukturu:

GetPage
  URL <adresa>?<parametry stránky>
  Referer <adresa, z které se na stránku odkazuje>
  Message <hláška, která se při provádění příkazu zobrazí v oknu událostí>
End

PostPage má tuto strukturu:

PostPage
  URL <adresa>
  Data <parametry stránky>
  Referer <adresa, z které se na stránku odkazuje>
  Message <hláška, která se při provádění příkazu zobrazí v oknu událostí>
End

V sekci přepínačů a sekci stránek lze využít těchto proměnných (viz příklad):

  • MyName - jméno odesílatele (načítá se z Nastavení)
  • MyEmail - email odesílatele (načítá se z Nastavení)
  • MyPhone - kompletní číslo odesílatele včetně kódu státu (načítá se z Nastavení)
  • MyPhoneNP - číslo odesílatele bez předčíslí
  • MyICode - mezinárodní kód čísla odesílatele (bez plusu)
  • MyPrefix - předčíslí odesílatele (bez úvodní nuly)
  • MyPrefix0 - předčíslí odesílatele (s úvodní nulou)
  • IPhone - kompletní mezinárodní číslo adresáta
  • ICode - mezinárodní kód adresáta
  • Phone - číslo adresáta bez kódu země (s předčíslím)
  • PhoneNP - číslo adresáta bez předčíslí
  • Prefix - předčíslí adresáta bez úvodní nuly
  • Prefix0 - předčíslí adresáta s úvodní nulou

Dále jsou k dispozici tyto funkce:

  • GetInput(Name, Num) - Funkce najde na stránce, která byla načtena v sekci stránek č. Num, INPUT tag, jenž má NAME=Name a vrátí hodnotu VALUE. Nepoužívejte u skrytých parametrů (info zde).
  • GetHost(Num) - Vrátí IP adresu ze které byla načtena stránka v sekci stránek č. Num (používá se při přesměrování).

Parametry a funkce jsou uvozeny znaky \% a končí znakem % (např. \%Phone%).

Sekce hlášek

Pokud chcete, aby DreamCom nějak reagoval na načtení (nebo nenačtení) stránky, musí za každou sekcí stránek následovat hláška. Hlášky mají následující strukturu:

Msg
  if "text hledaný na stránce" <příkaz> "text vytištěný v DreamComu" <modifikátor>
.
.
  if "text hledaný na stránce" <příkaz> "text vytištěný v DreamComu" <modifikátor>
End

Příkaz může být buď Print, pokud šlo všechno OK, nebo Error, pokud došlo k nějaké chybě. Modifikátory určují, jak se má DreamCom zachovat:

  • Success - zpráva je vyřazena z fronty a uložena do historie (odesláno)
  • Retry - zpráva bude ihned znovu odeslána (neodesláno)
  • Queue - zpráva bude odeslána za 10 minu (neodesláno)
  • Cancel - zpráva bude vyřazena z fronty (neodesláno)

Důležitá poznámka na závěr

Při vytváření skriptu ignorujte skryté parametry - input tagy, které mají type nastaven na hidden. Tyto parametry vkládá DreamCom automaticky.

Příklad skriptu

# Skript pro SMS branu Paegas
# Verze 1.0

Param
  Version 1.0
  CountryCode 420
  Prefixes 603;604;605;73
  FirstMsgSize 153
  OtherMsgSize 156
  MsgCount 5
  MsgTime 120
End

AoD
  On email=\%MyEmail%
  Off email=
End

Flash
  On mtype=2
  Off mtype=1
End

GetPage
  URL http://sms.paegas.cz/cgi-bin/sms/wwwsms
  Message Načítám úvodní stránku.
End

GetPage
  URL http://sms.paegas.cz/cgi-bin/sms/wwwsms?prefix=\%Prefix0%&number=\%PhoneNP%&text=\%Message%&submit=Odeslat&cntr1=777&key=\%GetInput(key,1)%&cntr2=0&\%Flash%&\%AoD%
  Referer http://sms.paegas.cz/cgi-bin/sms/wwwsms
  Message Posílám zprávu.
End

Msg
  if "va odesl" Print "Zpráva byla úspěšně odeslána." Success
  if "zkuste to za" Error "Zpráva bude odeslána později." Queue
  if "nka vypr" Error "Stránka vypršela." Retry
End


Registrace na MTNSMS

Dříve než začnete používat bránu MTNSMS, musíte se zde nejdříve zaregistrovat (zdarma).

Nejdříve vyplníte registrační údaje na http://www.mtnsms.com/registration/

Email musí být stejný jako máte napsaný v nastavení dreamcomu a pod kterým jste DreamComa zaregistrovali.

Heslo musíte doplnit v databázovém okně Skripty.

Poté kliknout na smajlika :) vpravo dole a na nasledující obrazovce doplnit kód, který přišel emailem.

Pak ještě kliknout dole na sms-xpress.

Ještě nastavte auto-login v Profilu http://www.mtnsms.com/members/profile.asp pro jednodušší přihlašování (není podmínkou) a zkontrolujte sms mode - musí být sms-xpress - důležité!!! Můžete si také nastavit podpis (default signature).

Na doručení zpráv se můžete dívat na http://www.mtnsms.com/sms/outbox.asp.


Registrace programu

Registrace programu DreamCom

Registrace programu stojí 100 Kč, tato částka zahrnuje upgrade zadarmo až do verze 5.0 (pro uživatele, kteří mají zaregistrovanou verzi 3.x funguje registrační klíč i pro verzi 4.x). Po registraci zmizí reklamní pruh a nutnost na něj klikat. Získáte také speciální emailovou adresu technické podpory.

Registrace je prováděna převodem na účet, je vázána k emailu, který máte vyplněn v nastavení.

Licencování:
Program můžete používat na libovolném počtu počítačů (doma, v práci, atd..) ale vždy ho může používat pouze ta osoba, na kterou byl program registrován. Na každých 5 licencí je poskytována 100 Kč sleva. Tedy za 5 licencí zaplatíte 400 Kč, za 10 licencí 800Kč atd.

Pokud se tedy chcete zaregistrovat pošlete email na chcidream@centrum.cz , zde uveďte:

  • Váš email, na který chcete program zaregistrovat
  • V případě, že potřebujete daňový doklad, uveďte tuto skutečnost a pošlete veškeré fakturační údaje, včetně IČO a DIČ

Druhou (a jednodušší) možností je vyplnit formulář na webu.

Obratem dostanete informaci o úspěšné objednávce a variabilní symbol, po zaplacení dostanete registrační soubor.

Domovská stránka DreamComu: http://dreamcom.d2.cz